Upgrading To 8.0 From 7.x

Please follow the below steps to upgrade the Laravel version in your exiting project.
  • PHP 7.3.0 Required

    Likelihood Of Impact: Medium

    The new minimum PHP version is now 7.3.0.

  • Updating Dependencies

    The following first-party packages have new major releases to support Laravel 8. If there are any, read through their individual upgrade guides before upgrading:

                
    Horizon v5.0
    Passport v10.0
    Socialite v5.0
    Telescope v4.0
                
              

    Finally, examine any other third-party packages consumed by your application and verify you are using the proper version for Laravel 8 support.

    You must have to update below mention packages in composer.json file.

                
    "require": {
      "php": "^7.3|^8.0",
      "fideloper/proxy": "^4.4",
      "fruitcake/laravel-cors": "^2.0",
      "guzzlehttp/guzzle": "^7.0.1",
      "laravel/framework": "^8.0",
      "laravel/passport": "^10.0",
      "laravel/tinker": "^2.0",
      "spatie/laravel-permission": "^3.8",
      "laravel/ui": "^3.0"
    },
    "require-dev": {
      "facade/ignition": "^2.3.6",
      "beyondcode/laravel-dump-server": "^1.0",
      "filp/whoops": "^2.0",
      "fzaninotto/faker": "^1.9.1",
      "mockery/mockery": "^1.3.1",
      "nunomaduro/collision": "^5.0",
      "phpunit/phpunit": "^9.0"
    },
                
              
  • In addition, the Laravel installer has been updated to support composer create-project and Laravel Jetstream. Any installer older than 4.0 will cease to work after October 2020. You should upgrade your global installer to ^4.0 as soon as possible.

    Authentication

    All authentication scaffolding has been moved to the laravel/ui repository. If you are using Laravel's authentication scaffolding, you should install the ^3.0 release of this package and the package should be installed in all environments. If you were previously including this package in the require-dev portion of your application's composer.json file, you should move it to the require section:

              
                composer require laravel/ui "^3.0"
              
            
  • Now run the below command to upgrade.
  •             
                  composer update
                
              
  • After successfully executing of composer update command check the Laravel version
  •             
                  php artisan --version
                
              
  • After successfully updated Laravel version. Run below command to serve your project.
  •             
    php artisan key: generate
    yarn
    yarn mix
    php artisan serve